EFT Issues NIPR Prod
Incident Report for AgentSync Statuspage
Resolved
This incident has been resolved
Posted Nov 07, 2024 - 14:16 MST
Monitoring
NIPR has reported a delay in processing EFT payments. In addition, the E-Commerce Reports are expected to be blank today. NIPR is working to get these issued resolved. Please contact niprcollections@nipr.com with any questions.
Posted Nov 04, 2024 - 11:30 MST
This incident affected: Providers (NIPR).